Problem with layout

Download and support for PhpBB3 PM Notify & Guest Register bar
Baylex
BBCoder I
BBCoder I
Posts: 2
Joined: 19 Sep 2011, 18:41
BBCodes: 0

Problem with layout

Post by Baylex » 19 Sep 2011, 19:05

Hi! I wanna congratulate you for developing such good modifications to phpbb!!
Alright, so the problem is that I'm having difficulties applying this modification to my forum.. my forum is http://www.apriliaclubeportugal.com and I'm using madevo style.. I think the problem is that madevo has already a infobar, and when I apply this one, they come together.. That's what I think..

Here is the forum in his normal state
Image

This is what appear to guests
Image

And this is what appear when I log in.. And if I send a private message nothing will appear...
Image


Some help please!
Thanks!


User avatar
Stoker
Site Admin
Site Admin
Posts: 3531
Joined: 12 May 2008, 21:26
BBCodes: 239
Favourite BBCode: Anipro
Favourite MOD: PrettyPhoto
Location: Denmark

Problem with layout

Post by Stoker » 20 Sep 2011, 04:46

Thats because the id info is in use by your style.

The solution is to uninstall completely and follow this directions instead.

Open styles/prosilver/template/overall_header.html
Find:

Code: Select all

<body id="phpbb" class="section-{SCRIPT_NAME} {S_CONTENT_DIRECTION}">
After add:

Code: Select all

<!-- IF not S_USER_LOGGED_IN and not S_IS_BOT and not S_IN_UCP -->
<div id="infopm"><div id="infobarpm">
<a href="{U_REGISTER}"><img style="width: 50px; height: 50px; padding-right: 100px; vertical-align:middle;" alt="" src="{T_THEME_PATH}/images/reg.png" />{L_PMG_WELCOME} {SITENAME}. {L_PMG_REGISTER}<img style="width: 50px; height: 50px; padding-left:100px; vertical-align:middle;" alt="" src="{T_THEME_PATH}/images/reg.png" /></a>
</div></div>
<!-- ENDIF -->

<!-- IF not S_IS_BOT and S_USER_LOGGED_IN and S_USER_PM_POPUP and S_DISPLAY_PM and (S_USER_NEW_PRIVMSG or S_USER_UNREAD_PRIVMSG) -->
<div id="infopm"><div id="infobarpm">
<a href="{U_PRIVATEMSGS}"><img style="width:50px; height: 50px; padding-right: 100px; vertical-align:middle;" alt="" src="{T_THEME_PATH}/images/mail.png" />{L_PMG_HELLO} {S_USERNAME} {L_PMG_YOUHAVE} {PRIVATE_MESSAGE_INFO}<!-- IF PRIVATE_MESSAGE_INFO_UNREAD --> {L_PMG_AND} {PRIVATE_MESSAGE_INFO_UNREAD}<!-- ENDIF --><img style="width: 50px; height: 50px; padding-left:100px; vertical-align:middle;" alt="" src="{T_THEME_PATH}/images/mail.png" /></a>
</div></div>
<!-- ENDIF -->
Open styles/prosilver/theme/colours.css
Find:

Code: Select all

/* Form button styles
Add after:

Code: Select all

/* PM Notify & Guest Register bar
----------------------------------------*/
#infopm {
    overflow: visible;
	min-width: 750px;
    width: 100%;
    position: fixed;
    left: 0;
    z-index:200;
    margin-top: -27px;
    font-family: Verdana, Arial, Helvetica, sans-serif;
    font-size: 1.5em;
	font-weight: bold;
}

#infobarpm a, #infobarpm a:link, #infobarpm a:visited, #infobarpm a:active {
    display: block;
    float: left;
    width:100%;
    clear: both;
    color: #fff;
    padding: .85em 0 .85em 0;
    border-bottom: .25em solid #fff;
	text-align: center;
    text-decoration: none;
	background-image: url("{T_THEME_PATH}/images/pmreg.png");
	background-position: bottom;
	background-repeat:repeat-x;
}

#infobarpm a:hover {
    color: #fff;
	background-image: url("{T_THEME_PATH}/images/pmreg.png");
	background-position: top;
	background-repeat:repeat-x;
	border-bottom: .25em solid #fff;
	cursor: pointer;
}
You may have to adjust this: margin-top: -27px; to your style

Open language/en/common.php
Find:

Code: Select all

?>
Add before:

Code: Select all

// BEGIN PM Notify & Guest Register bar
$lang = array_merge($lang, array(
    'PMG_WELCOME'		=> 'Welcome to',
    'PMG_REGISTER'		=> 'Click here to register', 
    'PMG_HELLO'			=> 'Hello',	
    'PMG_YOUHAVE'		=> '- You have',
	'PMG_AND'			=> 'and',
));
// END PM Notify & Guest Register bar
Board rules! No PM support
Sure, I can install the Mod for you ;)
Like the site? Then buy me a bear

Baylex
BBCoder I
BBCoder I
Posts: 2
Joined: 19 Sep 2011, 18:41
BBCodes: 0

Problem with layout

Post by Baylex » 20 Sep 2011, 09:44

Yes that's what I though the id wal already being used by the style.. but you solved it!
Thanks very much it worked like a charm ;) THANKS!!